Calendar reappears after deselecting

I have a specific calendar that I do not want to see in a Smart List. Within ‘Settings - Lists & Calendars’, I have turned off (unchecked) the calendar that I do not want to see. When I come back to GoodTask, the calendar is checked and shows up in my Smart List. I cannot seem to turn off the calendar. Also, the calendar in question is unchecked in the native iOS Calendars app and does not show. Any idea why this calendar keeps turning back on (becomes checked when I have unchecked)?

Hi @wbw06180, thanks for using GoodTask.

Currently there is a bug while adjusting calendars on some cases like you've mentioned. It'll be fixed on next update. Meanwhile, if you run 'Settings - Advanced - Reset Calendar Connection', it should be fixed. You may need to reset lists and calendars settings afterwards.