iOS13 GM - not working


Hi! Just upgraded to the GM and now GoodTask isn't working. I didn't upgrade the database yet because Catalina is now delayed.

Here's what I'm seeing:

  1. I can't see any of my tasks in the list, day, week, or month views. Calendar items do work.
  2. When I look at the "list of my task lists", I see all the count of each list being correct.
  3. Smart Lists don't have anything.
  4. Adding a new task doesn't work. Tried with both dated and undated tasks.

I'm sure this is due to the GM because everything was working beforehand. Any thoughts?


Ok update: working now!
Settings... Privacy... Reminders.... Turn OFF GoodTask.
Launched the app.
Then go back to Privacy settings and toggle it back to ON.

Looks like a bug to me.


Hi @lyleberman, thanks for the feedback. It's probably because of loading the data in Reminders app. I'll take another look. Thanks!

1 Like

Hi, I'm also having this issue with iOS13 and the above didn't fix it.


Hi @cyan, would you give me some more detail on how it behaves? Thanks!


Hi, I'm experiencing some of what lyleberman posted above.

No tasks show in list, day, week, or month views. Calendar items do show.
I can go through the motions of pulling down and adding a new task, but it doesn't actually appear.
The counts in my "list of my task lists" all appear to be correct, except "All Lists" -- it says "0"

This only started after I upgraded to iOS 13. All the data is still in the Reminders app, and I've tried uninstalling/reinstalling GoodTask to ensure they're linked. Also, I only use GoodTask on my phone, so no syncing between devices.



Hi @cyan, check below post. It could be due to performance issue. If this is not the case, please tell me back. Thanks!