Tasks different between phone & watch

#1

Hi Kim, since upgrading to iOS 13 & Watch OS 6 I'm having some issues with the 'Focus' task list I've set up. This takes the content from 5 lists and displays items due today. Under the prior OS's it worked perfectly. Now when I look at the app on the watch it shows 25 items (correct), but the watch only shows 8 items. Removing the app from the watch fixes the issue but only for a few minutes, then the tasks shown reduce again.

I've not been into the native Reminders app so the database has not been upgraded as I need functionality across the iPhone, Mac and iPad.

Hope this is a know problem, with a fix in the pipeline.

#2

Hi @Daron_Brewood, thanks for the feedback.

Would you give me some more details? Do you mean you see 25 on iPhone and 8 on the watch?

Also check default Reminders app on Apple Watch to see if it gets data properly. Thanks!

#3

Yes 25 on the phone 8 on the watch. If I remove the app from the watch and re-add it the 25 tasks are visible for around 30 seconds then it seems to refresh and drop to 8.

The native reminders app I’ve avoided in case the database updates. However the reminder system seems to be okay as the tasks sync over to GoodTask on the iPad and Mac with no problems.

#4

Just checked the reminders app on the watch that only shows the (latest count) of 7 tasks. On GoodTask on the phone the specific task list counts 31 tasks at the moment. Do you want me to go into the native reminders app on the phone and choose not to update the database?

#5

You can go into the Reminders app and use it without upgrading the database. But I guess the issue is on the watch so the Reminders app on iPhone won't matter much.

GoodTask on Apple Watch fetches data from the watch itself and if the watch doesn't have proper data, it won't show it properly. If Reminders app on Apple Watch doesn't show proper data, something is going wrong.

It could be an issue that needs some time. Try editing/adding tasks on Reminders app on the watch and see if it triggers anything.

#6

Just been in the native reminders app on the phone (chose not to upgrade) and the reminder count in the App is correct again incorrect on the native reminders app on the watch.

#7

Nowadays watchOS keeps data separately from the phone. Normally it should match but sometimes things like this happen. :disappointed_relieved:

#8

Does not reassure me that I can’t see the reminders app on the watch in settings. Annoying though that it worked perfectly until the new OS’s were installed. I guess first step is to unpair the watch and re-pair to see if that works.

#9

Yeah, I think Apple should have given more care on Reminders connection to Apple Watch. :disappointed_relieved: