App is hanging at every click

Starting today, the app stopped working normally. Now, every interaction I make with the app, like scrolling or click a task triggers a rainbow loading on the mac and it hangs in there for like a minute before being available again. Then, after I click anything, it goes back to the "hanging rainbow".

I tried deleting the app and installing again, but it didn't help. What else can I do?

Hi @Luis_Novo, thanks for using GoodTask.

Would you try re-installing the app after cleaning? You can do it by following below order.

  1. Close and un-install the app

  2. Delete preferences file

  • Open Finder

  • On top menu, choose 'Go > Go to folder..'

  • Copy below and move to the folder
    ~/Library/Containers/com.hahainteractive.GoodTask3Mac/Data/Library/Preferences

  • Delete com.hahainteractive.GoodTask3Mac.plist

  • On top menu, choose 'Go > Go to folder..'

  • Copy below and move to the folder
    ~/Library/Group Containers/

  • Delete U57829932E.group.hahainteractive.goodtask3

  1. Reboot the device
  2. Re-install the app

If this doesn't resolve the issue, try resetting database with iCloud settings.

  • Close Reminders and GoodTask.
  • Go into 'System Preferences - Apple ID - iCloud'
  • Check off 'Reminders'. This will remove Reminders data on your device.
  • Check back on 'Reminders'. This will re-download all Reminders data.
  • Open Reminders and wait to see download happening.
  • After all data is downloaded, open GoodTask and see how it goes.

If this doesn't work either, you may need to manually check lists if any lists are causing false behavior. To do this,

  1. Go into 'GoodTask - Preferences - Lists'
  2. Uncheck all but one list and see how things go.
  3. Check one list at a time and check the behavior.

There are sometimes a specific list which causes false behaviors. If you can find that list, making a new list and then moving the task to that list could resolve the issue.

If it still doesn't work, send me some details about your status including screenshots or screen recordings to contact@hahaint.com

Thanks!