Auto Snooze settings

I have auto snooze alerts (every 5 minutes for 5 times) set up, but only the first alert every activates so the behavior is as if there is no auto snooze at all. Am I missing a setting somewhere that is keeping from the other alerts from coming on every 5 minutes?

This is on iPhone XS Max with iOS 13.3.1 and GoodTask 5.3.1.

Hi @brudderman, thanks for the feedback.

The screenshot seems fine and it should work properly.

Do you see this on every task with auto-snooze set? (first alert fires only?)

Thanks!

Yes, this is the case with every auto snooze. Only the first alert fires now even though in times past it worked correctly.

Hmm, that's pretty weird.

  • Would you check settings inside 'Settings - General - Notifications - Auto-Snooze' and see how it's set?
  • Would you try with a test task with auto-snooze every minute 5 times and see how it goes?

Thanks!

The auto-snooze notifications were off so I turned them off. Then I turned the phone off and then back on and created a new Test reminder with an auto-snooze of 5 times for 5 minutes. The results are the same: only the first notification fires and the others do nothing. Screenshots attached.

Thanks for the info. It seems a bit odd. Do you have lots of tasks with alerts?

Try choosing None inside auto-snooze settings and set one for detail task.

Or try choosing an option such as every minute five times and make a tasks with alert.

If you have settings set, you don’t need to add auto-snooze settings for each task.

Thanks!

I’m not sure I understand your instructions. I have about 70 reminders with alerts, but only 2 or 3 of those are auto-snooze. I set the General auto-snooze settings to None and created a new Test reminder task and set it to 1 per minute for 5 minutes. Only the first one fires. But maybe you meant for me to do something else that I just didn’t understand.

Do they come in same day? Normally alerts are set from upcoming ones but there is a limit that the app can set at once. To debug, please check by setting Lists inside notifications option which will filter lists that will run notifications.

If it works, please send me details of your tasks with alerts to hanbum@hahaint.com I’ll need to investigate further.

Thanks!

I have deleted all auto-snooze settings except one, put it in it's own list all by itself, filtered that list alone to use auto-snooze, removed all other auto-snooze settings from other reminders and did a hard reset of the phone. Still no luck in getting it to work.

At this point I think that I need to just start from scratch instead of trying different settings. If all of my reminders return OK, then I will try one auto-snooze and see if it will work. If so, then I will add them back one at a time. With this approach in mind, I have a couple of questions:

  1. Is there some setting in the app to reset the settings back to their original states? I could try that.

  2. Otherwise, I think I will delete the app and reinstall a new copy. If I do this I know that I will lose things like smart lists and auto-snooze settings and maybe other things. But if I just get back all of my reminders, that will be OK. Quite a few have custom monthly repeats such as 2nd Tuesday, Last Workday, Last Wednesday, etc. Would be good if those come back as well.

Concerning auto-snooze, it would be nice to be able to look at the list of reminders and see the little auto-snooze alert icon to distinguish those from regular alerts.

Thanks!

Thanks for the feedback. I’ll consider things you’ve mentioned.

Even if you reinstall the app, all settings could come back in due to iCloud sync though.

If you figure out any related cause of the issue, please let me know. Thanks!

I have tried several other things without success in getting the auto-snooze working again:

  1. Pruned all completed tasks older than a month and did a hard phone reset.
  2. Tried all the built-in auto-snooze settings (1 time per minute for 5 times, etc.)
  3. Tried custom settings (1 time every 2 minutes for 3 times, etc.)

I don't know of anything else to try but am open to further suggestions to get this going again. Since it used to work, surely it is likely related to updates either in iOS, the app or both. If it makes any difference, I still haven't updated Reminders in iOS since my Mac can't be upgraded beyond High Sierra and doesn't support the updated Reminders.

This is an important feature to me, and I'd sure like to have it back working again!

Thanks!

Hi @brudderman, thanks for the details.

Would you try below?

  • inside Settings - General - Notifications, select List option to one specific list for testing
  • make a test task in that list and set alert after a minute from now with auto snooze one minute five times
  • check how it goes

Thanks!

Thanks for trying to help me sort it out.

This is how I set it up with just the Auto list filtered to be for auto-snooze. Then with one item Test in the Auto list set for 9:25 and then auto-snooze every 1 minute for 5 times thereafter. If that’s not what you want, let me know how to adjust it.

The notification sounded on time at 9:25, but no auto-snooze at all happened after that.

Please try testing with 'Notifications - Lists' filter. Not the one inside 'Auto-Snooze'.

Thanks!

OK. Some progress. With one list selected (Auto) as you suggest with a single item in that list, the auto-snooze works as expected. It also works if I add a second small list so that both are selected (Auto and Grocery) with an auto-snooze item in each list. Both items auto-snooze. But if I select my main Reminders list with 70 items as the only selected list, auto-snooze items in that list activate only the first time but don’t auto-snooze. Bottom line: small lists seem to work but the large list doesn’t.

I can try other things if that will help. Just let me know what to do.

Thanks for the info.

Do you manage tasks with alerts only or do they all have equivalent or similar due date/times?

There is a limit of 64 notifications that can be set at once and normally GoodTask sorts them with due date and cuts it from that. Since you have lots of tasks with notifications, this may be hurting the addition of auto snooze notifications.

Are you in the beta program at the moment? I've made some adjustments and if you want to test right away, send me your email to contact@hahaint.com Thanks!

I use Siri to add reminders for various tasks as the need arises, so the due dates usually vary. Some tasks repeat daily, monthly, yearly or perhaps with a custom interval such as every 3 months on the last Wednesday. The Reminders list is the largest with about 70 right now. Shopping lists have items with no due dates, and Siri adds those as well. I expect that the number of reminders is the culprit but don’t see how to reduce them.

I’ll send you the email and check out your adjustments if you want me to. Thanks for trying to help me!