Can't unlock iPad app

I recently bought the Mac App Store version of GoodTask on my Mac and unlocked it on my iPhone. However, I can't unlock it on my iPad. Whenever I try to either restore purchase or click support (I thought maybe it was a separate purchase on the iPad) I just get a black screen with a spinning wheel in the middle of it that doesn't go away. I've tried numerous times, left the app for long periods of time and whenever I come back to it, it's still on the same black screen and has to be force quit. There was an update for the app this morning, but even after applying the update I still have the same issue.

I've now been charged for the in-app purchase on both the iPhone and the iPad (it wasn't made clear anywhere that I"d need to buy it on both platforms), but it's only worked on the iPhone. On the iPad I still get the message 'waiting for your support' and have the yellow daisy icons as opposed to the green tick I have on the iPhone.

Hi @dagaz, thanks for using GoodTask.

Normally if you see only supporting options, it’s already unlocked. Supporting options have been added after many updates which had been done for years.

I’ll try to improve the message to make it more clear. You may ask Apple for refund for the purchases that’s not intended.