Current Status of GoodTask for iOS 13 beta (Update 7/8)

Not to get anyone too excited but I notice that the latest update (4.7) seems to bring back integration with iOS 13 reminders. Sine this update,I have been able to use full filtering and such again.

1 Like

Goodtask crashes when marking a task as done, public beta, after reminders database upgrade, used to work fine before that

Hi @pzol, thanks for the feedback. This seems like a random bug on iOS beta which happens to some users. Does it happen to you always when you complete tasks?

Actually, it’s on one task only, consistently. But cannot figure out what’s so special about this task

Thanks @pzol for the answer. If possible, please send me screenshot of that task to I'll take a look. If it's consistently happening, is it recurring task? Thanks!


Public beta 2 is still crashing when I complete or reschedule certain tasks. I’ve not been able to spot a pattern but new reminders added since the update seem ok.

Unfortunately it renders the app unusable atm. Any tips? I’ve uninstalled and reinstalled to no avail.

Many thanks,

Hi @Themikeyd, thanks for the report.

I'm seeing the reports but I couldn't reproduce it on my test devices. It seems like a random thing.

I've sent Feedback Assistant about the issue. I recommend you to send one too after the crash happens on the device. It'll be better for Apple to see the diagnoses directly from the device it happened.

If you find any patterns, please tell me back. Thanks!

I don't know if this helps. I am now getting the crashing again with latest beta. Initially it seemed to be OK but it's crashing again.

One thing I am seeing is that I can complete overdue tasks and they complete, disappear and everything is great. If I complete a future task it crashes. This is repeatable.


Hi @IanT, Would you give details of the task that's crashing? I've tested multiple tasks with future due date, recurring or not, updated database or not and can't reproduce it. Thanks!

Not sure how to share details but here is a link to an image of the task.

Does this help?

Yes, thanks for the info, @IanT.

According to your screenshot, your task has invalid start date. Currently start date on recurring tasks doesn't work properly. (This was a bug before iOS 13 but it got worse on iOS 13.) But your task seems to have start date later than due date (according to -7 hour duration shown). I'm not quite sure what may have caused it since you're not using start date in the settings.

Please try changing start date by going into 'Settings - General - Use start date' and edit start date to match due date or make it earlier than due date.

If you know how this task got this way, tell me back. Also if you have other tasks that crash, give me a screenshot like this too. And also please share how above procedure went.


I've seen a number of my tasks with -7h as you mention. Obviously I didn't set them up like that.

Do you live in GMT-7 time zone? This could be the reason. DB1 & DB2 had the issue of making wrong start dates when you add a new task.

I live in Vancouver so I would call it -8 but with summertime I guess it could be -7.

I enabled start date in settings. Went to the Task and changed the start date to now. Then I used the back button to go back to the list and save the task. It immediately crashed. When I relaunched the task still had the erroneous start date so I tried again and it crashed.


Does other tasks which are not recurring behave the same? You might need to make a new task for the one that's crashing.

So it seems not. Also this recurring one doesn't crash it.

A new repeating task with the same details doesn't crash it.

It seems like repeating tasks that's made in DB1, DB2 (PB1) is causing crash when your time zone is GMT-N.

There seems to be no particular way to resolve it. Current workaround would be adding a new one and delete the current one.

I'll keep an eye on it. Thanks!

So I’ve cleared the issue for now. It seemed to be my overdue items which are the ones I was trying to reorganise therefore giving the appearance that it was app wide. I created a new todo and couldn’t reproduce the issues. I noted that completing an item crashed the app but didn’t mark item complete. However rescheduling crashed the app but DID complete the reschedule.

So I rescheduled everything to today and then tried again.....everything was working.

Perhaps this forced the todos to the new database in the correct format?