Language on Apple Watch app

I switched my default language (Portuguese) to English a couple days ago, just to check something on the phone app, and switched it back a few minutes later. And it affected my Apple Watch as well, but it only changed from Portuguese to english, and now it doesn’t change back to Portuguese on the Apple Watch.
On the iPhone app everything is fine, it’s all in Portuguese, but I can’t make it change on the Apple Watch app.
I’ve tried to reboot both the devices, changing it once again just to see if it would work but nothing changes.
Is there any other way to force it to go back to Portuguese?

Hi @AlexandreFalcao, thanks for using GoodTask.

Try opening Watch app on iPhone and go into General - Language & Region and see how it's set.

If it's properly set, try adding or adjusting 'Portuguese' in default Settings app. You may try adding 'Portuguese - Portugal' and move it up in preferred language if needed.


I had the same and solved it by deinstall/reinstall the watch app from the iPhone app. (toggle the switch off and on)

1 Like

That solved it, thank you!!!