Lists and Tasks on both iOS and MacOS keep disappearing

#1

Hi,

I am a new GoodTask user and have been enjoying the app immensely having moved across from OmniFocus. However, today I have been experiencing issues across all of my devices with tasks and lists disappearing. A couple of times I restarted my iPhone and they all came back okay once the device had rebooted. I checked the settings in Reminders, that there was a default list, as per the warning message which pops up when it suggests there are no lists, and everything seemed okay. And now I have just restarted my desktop Mac, as it was suggesting I check that GoodTask had access in the Security settings under reminders, which it did; although it was also telling me there were no lists, even though they were all showing present and correct in the List settings within GoodTask.

Three lists have now lost all of their active tasks but seem to have kept all of the history of the completed tasks. And my Family list is the only one with active tasks left. It isn't set as my default on any of my devices. I am totally confused as to why I keep losing these tasks and lists and needing to restart the app and devices that it is on. I have lost roughly about four days of setting up tasks for my work projects. Any help would be much appreciated. Especially if I can somehow get the tasks which have mysteriously disappeared off my devices back.

Thanks in advance.

#2

Hi @ajph1970, thanks for using GoodTask. GoodTask uses default Reminders app's data so if there's something wrong with the data, first thing to check is the default Reminders app.

Normally if connection from Reminders app to the database gets loss, data could be missing. Make sure you have all the accounts properly connected to Reminders app inside default Settings (or System Preferences on Mac).

Check iCloud account and if they're all well, try restarting the device and see how it goes.

Thanks!

#3

Hi,

Thanks for the swift response. I am loving GoodTask. It’s approach to leveraging the stock Reminders app’s core functionality and turning it into a powerful task manager is superb. Very impressive.

I did check the stock Reminder app when I was having my problems with GoodTask yesterday and the data was certainly corrupted in there also. All of the lists were visible to me everywhere, in GoodTask and stock Reminders, when the data started to mess up. They were just blank with no current tasks showing and only completed tasks for most of the lists. The lists started disappearing after reboots of devices. I went into GoodTask on my MacBook Pro after posting my initial post here and some of the data came back for one of the lists but other data was permanently lost.

I think the issue may be other apps using the reminder data as well as GoodTask. I had Due app on my iPhone and went in there yesterday to see how it worked alongside GoodTask (although I think Due is now redundant for my needs). Also I have a new calendar app which also accesses Reminder data. Perhaps they all tried pulling data at the same time and crashed the database somehow.

I will keep to using GoodTask and stock reminders and see how it all goes.

Keep up the excellent work that you’re doing.

#4

Thanks for great feedback. :slight_smile:

You may want to check other apps like you've mentioned. Some of them reads Reminders data and removes them after adding it to their database.

Thanks!

#5

Out of interest is the other calendar app you are using Fantastical 3?

I have had tasks disappearing from Reminders lists for a week now. I would put the tasks back in and then at some point they would disappear. The only thing that had changed in my set up was installing F3 on my iPhone, iPad and Mac.

I have since removed all access to Reminders in F3 on all devices and the disappearing task issue has stopped. So whilst that is not concrete proof of where the issue is it is enough for me to not allow F3 access to my local Reminders lists.

Interesting Exchange tasks from an account set up directly in Fantastical doesn’t have this issue. It is only the Reminders tasks that do.

#6

Hi,

No, it wasn’t Fantastical 3. I was a Fantastical 2 user, but since the switch to subscription I no longer use that calendar. That’s a bit of a sore point for me, but not for discussion here.

I think the issue for me was that Due app, and Agenda (an app I was trialling) deleted Reminder data once they pulled them all into their databases. That was enough for me to stop using both apps as there appeared to be no way of stopping that behaviour in either app’s settings. A big no no for me.

The calendar app I was referring to is Calendar 366, which I switched to after ditching F3. It works seamlessly with GoodTask and is pretty much the same as F2 was and at a very affordable one time purchase cost.

If you are struggling with F3 and Reminder integration it sounds like it may be a bug in F3. I have heard the new version seems to be suffering with a lot of them right now.

Sorry I can’t be of more help regarding F3 but I wish you luck in sorting the problem out.