Redundant Tags, when I create a Task on a Smart List

This feature that all filter tags are automatically added to a new task is really helpful!
So when I have a smart list w/ for example this filters:

  • #feat1
  • #feat1 OR(1)
  • completed AND(2)
    a redundant "#feat1 #feat1" will be added to the notes field.

Hi @pfke, thanks for the feedback.

If you have 'Settings - New Task - Contextual: List' option turned on, tags should be added when new task is made on that list. Thanks!

Maybe I expressed myself in a misleading way: I meant, "#feat1" is added twice.
On a smart list, when I have two (or more) filters with "Tag: #feat1".
For every single filter condition, the tag text will be added to a new task. No matter if a tag with the same name was added before or not.

Ah, got it. I'll take a look. Thanks!

I have a related situation that might be a bug. Seems to be the case in both iOS and MacOS.

I have 'Settings - New Task - Contextual: List' turned off. While in a smart list and in board/date view, if I create a new task using the small '+' button at the bottom of a board, the new task uses the default new task list (as it should) but it pre-populates with the selected smart list's tags.

If in board/tag view, the same things happens but the new task also includes the tag of the selected column.

This only happens in these specific instances, creating a task using the plus button in board view. If I create a new task any other way, the expected behaviour (default new task list, no tags) occurs.

Hi @djb21au, thanks for the report. I'll check and will fix it soon. Thanks!

+1 for a fix for this.

Seeing the same behaviour with my smart lists too. It is using a tag that I have set the smart group to filter out (under certain conditions) so it is a bit of a pain that it is being added by default.

Hi @oddballs, thanks for the feedback. Above described bug has been fixed at the time. Would you describe with more detail about your issue? Thanks!

Hi @GoodTask -

My smart list has the following filter set up (it was based on one i found on this forum and works as I need it to).


If I add a new task when I am in this smart list however a tag of #waiting is automatically applied - which I do not want. Is there a way to prevent this?

Hi @oddballs, thanks for the details. Since you have 'included' tag filter, it adds the tag when you add a new task. You can turn it off by changing option 'Settings - New Task - Contextual List' to off.


OK - will do. But then I have to select the desired list when adding a new task?

Either way there is an extra step involved that is undesired (either deleting an erroneous tag or selecting the desired list). Could 'Tags' not be added as one of the Contextual options?

I'll keep it on the list to consider. Thanks!

1 Like