Running into Glitches

I’m running GoodTask on my iPhone 7 Plus. I’ve made sure that the app is up to date. This week I keep running into glitches. At one point in the week all of my notes that I had updated the night before turned into tasks in my inbox. Several times this week tasks and subtasks that I’ve completed will complete and then immediately incomplete again. Is there something I need to change in my settings or do to help everything run smoothly again?

Hi @SIGFY, thanks for the feedback. I'm not exactly sure what your situation is. Using fewer lists or database could improve performance if you have big database. I'm working on an update that would improve overall performance at the moment.

If you can get exact symptom of an issue or get a screen recording of the issue, it would be helpful. You can send it to me on


1 Like

I don’t know if it’s related by I also run into issues with my iPhone. Board view is quite slow, scrolling within a board keeps reverting back to the beginning of the task list, and the biggest issue is that when I open GoodTask, tasks often need way too long to appear (I’m talking in minutes). I’m considering switching to Todoist :slightly_frowning_face:

1 Like

Also, half of the tasks I worked on yesterday on my iPhone weren’t sync with Reminders, and I’ve lost everything I did with them yesterday :disappointed:

Would you send me details about your device and settings with screenshots to It doesn’t seem like normal case. Thanks!


Thank you! I will see if I can catch it when it happens again. I've already corrected what I've caught so far. I appreciate your responsiveness!

1 Like

I was able to catch one glitch on a screen recording. I have emailed it to you. Thank you!

1 Like

Now my Quick Actions are no longer showing up for me. They are still in the app, but not showing on the tasks.

Hi @SIGFY, thanks for the feedback. Seems like you're in 'Focus' mode which hides things and shows notes, subtasks only. You can toggle it by tapping 2nd button on top right. Thanks!

1 Like

Thank you so much! That worked! I didn't realize that is what that button was for. I must have hit it accidentally. Thanks again!