When I try to create a new task using shortcuts, every time I get an error - cannot communicate with helper application. Has anyone been able to get shortcuts working with GoodTask? I am also having a problem with widgets not working. I don’t see any one else having problems with this. What am I doing wrong? I have tried everything. Resetting the cache, reinstalling the app, resetting my phone, etc.

Thanks for any advice!

Hi @kkay5, thanks for using GoodTask. I’m not seeing any particular error with shortcuts or widgets. Try restarting the device and if the issue persists, send me screen recordings to


I have reset my phone a ton of times, but I did it again and it’s still not working. What should send screenshots of? The error message I am getting and my shortcut? I know I am setting the shortcut up right, because it worked at the beginning and then just stopped working. I just have no idea what else to try!!!

Send me some details inside GoodTask and how you’re running the shortcut. Below link is explanation for how to record screen on iOS devices.