Tasks wil not appear on watch with WatchOS 6

#1

Hi,

I'm using GoodTask for a year now on my iPhone/Mac and Watch and it work fine... till the update of iOS 13. I've updated my reminder items after the update of iOS 13.
I use GoodTask 4.8.5 but the open tasks doesn't appear on my Apple Watch anymore. I use the complication of GoodTask and now there is always the V shown.
In the settings of GoodTask by complications I choose 'Count' by Circular.
Also when I open the app on my watch there are no tasks shown. I've restarted my iPhone and Apple Watch but nothing helps.
Is this a known problem or do I something wrong?

Best regards,
Sander.

#2

It's not a GoodTask thing, There is a sync issue for the IOS reminders in general on the new ios versions. It's doesn't seem to affect all users but many have reported about it in different forums. Since the update to IOS 13, my reminders haven't synced in any functional way between my iPhone, iPad and particularly my apple watch. So you might, like me, have to wait for the next IOS release, which will probably come in the next days.

#3

Thanks, i see the problem. Also on the reminders-app there are no tasks. I will wait for updates of iOS.

#4

Hi @Sander_Fickweiler, thanks for the feedback. You may need to reset and restore your Apple Watch to get it to download the data. I wish it can be resolved by an update. :sob:

Thanks!

#5

Thank you, that did the trick!

#6

Great that it works for you!

I also tried everything on "my side" (unpairing, resetting, disconnecting, de-installing, pairing as new watch, etc, etc) several times. Even have a support case with the "senior" support on Apple but they will not solve it with anything less than a patch. My reminders do sync occasionally but absolutely in no consistent way . something is definitely not as it should with the iCloud reminders sync.

#7

So just spoke to Apple senior support who confirmed they are having general problems with the iCloud reminders. New updates will come, probably for all 3 (iPhone, iPad and Watch) but he didn’t know when.

1 Like