UI Locked up

#1

When I open GoodTask the ui just locks. Cannot click on anything. I uninstalled and reinstalled and it is at the same point. Been like it for a few days now and not sure what else to do.

Is there a way to extract the configuration so I have a reference and then clean it? Is it stored in reminders somewhere?

#2

Hi @Sytone, thanks for using GoodTask.

  1. Is the app frozen and doesn't work at all? Please give me more details about the situation. If it's frozen, please wait a moment and see how it goes. Also check if the app crashes or not.

  2. Do you remember what happened before this started to happen?

  3. Would you try opening Reminders app and see if it's ok?

Thanks!

#3
  1. Frozen, it just lists all the lists and after a minute crashed out back to the IOS app list.
  2. No, it just started happening a week ago or so.
  3. Reminders is working fine and showing all tasks without a issue.
#4

Thanks for detail answer. It seems like a rare case. Would you give me some more info below?

  1. There has been 2 updates recently which are 4.7.0 (approx. June 27th) and 4.7.1 (approx. July 3rd). First one brought 'Task Display' option. Have you tried using this option? Do you recall when it happened approximately according to those 2 updates?

  2. What device and iOS version are you using?

  3. Do you use only iCloud as Reminders database?

Thanks!

#5
  1. Possibly around the end of June date, I do not remember using the Task Display option but may be wrong.
  2. iPhone 7 Plus running 12.3.1
  3. No, I have iCloud, Exchange and Outlook
#6

For testing purposes I disconnected reminders for outlook and exchange, checked via the reminders app they are gone and then loaded good task. it still locked up. Tried kill and reload and still locked up.

#7

Thanks @Sytone for detail info. Have you tried updating to latest v4.7.2 ? If it's the same, please send me an email at contact@hahaint.com I'd like to debug through beta build if it's ok with you. Thanks!