Upgrade problems

#1

Upgraded this evening. Finally got a sync that brought back my tasks. All seems well except, if I enter a subtask, Goodtask crashes. If I try to put a tag on an existing task using the Quick Action lists, Goodtask crashes. I haven't tried to reload because I know the Smart list arrangements will be gone.Not Happy.

#2

Hi @Drbj, thanks for using GoodTask.

Would you send me an email to contact@hahaint.com with some more details? I've checked and there is a bug on v4.9.4 iOS version when you have large settings with Apple Watch usage but couldn't find any other reports.

Your devices, iOS version, database type, lists status and screenshots would be helpful. Thanks!

#3

I think its solved, sort of. It could be a bug, but more likely a corrupted data entry in an existing task. I had not upgraded Goodtask, but had upgraded to IOS 13 on my iPhone 7. I also have a seriously outofdate iPad that I use as a text reader. (Reminders upgrades are incompatible with IOS ver. 9.)
Before i upgraded Goodtask i wanted to edit my task list and set a backup in iCloud. One of my edits was to add 3 more Contexts to an existing Context Quick Action switch and then use them to contextualize several tasks. The editing of the switch did not go well. There is no easy means to add New or delete Old contexts to a switch list, and reorganize them manually or alphabetically. I selected one task to test the new context switch list. On entering the new context through the Quick action list Page immediately crashed Goodtask. Then nothing worked it crashed every time I paused after a data entry. To fix it I tried everything, all upgrades, including upgrading Reminders, rebooted IPhone and Goodtask several times. I did not delete Goodtask and or reinstall. I tested throughout and the crash persisted, at one point any edit to any task crashed Goodask. However, after the night off I found that the crash occurs only when trying to edit the task I used to do my tests yesterday. Duplicating that task duplicated the crash condition. Changing anything in the task crashed Goodask. So i carefully reconstructed that task and deleted the faulty one. All edits to the new copy work... no crashes. The new edits to the Quick Action Context switch also work, and on other tasks. So far... so good. But now I have a new iPad to think of buying...

#4

Hi @Drbj, thanks for details. I'd love to know details about that corrupting task if possible. I assume you already removed it but if it happens again please share more details about the task. (I hope it doesn't happen though. :wink:)

I'll keep on improving the app. Thanks!

PS. I really like the new iPad Pro :smile: