Bug in Mac Ver 7.3.3 since Ventura 13.2.1

When I edit the due date of a task, the change often reverts to the original due date and the task reappears in the list with the original due date. If I then change it again, it usually works.

Hi @TRq, thanks for using GoodTask.

Would you try updating macOS to the latest version and see if the issue persists? If the issue persists, please share screen recordings to contact@hahaint.com Thanks!

Looks like, the Update to Ventura 13.1.2 (ore the mere reboot of the system) solved the problem.
I keep you posted

Sorry, I have to say: The update to newest Ventura did not help.
ANY change is being reverted - most of the time, if I repeat the change, it is accepted.

After I had rebooted the MacBook the problem is not there anymore
(have not tried to restart GoodTask and/or Apple Reminder)

Any changes are being “snapped back”.
Most of the time. When I repeat the change, it is accepted eventually.
Restart of GoodTask did not help.
The problem exists regardless of whether Apple Reminder is running in the background or not
(Ventura 13.3.1 (22E261))

Would you try changing value in Reminders app and see how it goes?

In Reminders, changes work right away

Hi @TRq, thanks for the answer. Would you try 'Settings - Advanced - Delete local cache files'? If it doesn't help, try 'Reset calendar connection' too. This will reset settings for smart lists and quick actions related to lists so if you have many settings, you need to take care of this later on. Thanks!

Deleting the local cache did not help.

I haven't tried resetting calender settings. I first have to jot down all my settings for smart lists and quick actions so I can re-establish them afterwords.

I did reset calender settings. The problem war gone for a few days. Now, it's the same as before.

Same problem here (macOS Ventura 13.3.1, GoodTask 7.3.3). Rebooting helps, but the behaviour is back after a while (eventually after waking up from sleep mode?).

Hi @dvdweyer, thanks for the feedback. Have some questions.

  • So change made at first doesn't stick and if you do it again, it sticks. Is this right?

  • Does this work like this all the time until restart of the device? (Restarting the app doesn't help?)

  • Does all changes such as priority change behave the same?

  • Do you use iCloud as main data source?

  • Does Reminders app work properly when the issue is occurring on GoodTask?


indeed: first doesn't stick and if you do it again, it sticks. I've noticed it mostly (but I think not only) with Subtasks in GoodTask.

  • I thought earlier (could be 1-2 weeks ago) restarting GoodTask did not work. Now restarting GoodTask without rebooting works, at least for the moment.
  • The behaviour was most pronounced with Subtasks. Changing the priority did work directly, even when GoodTask showed odd behaviour with Subtasks.
  • I use iCloud as main data source.
  • Reminders app works properly when the issue is occurring on GoodTask. This includes Subtasks, if I change "[ ]" to "[x]" at a Subtask in the note attached to the task in the Reminder app.

I just restarted the app, at the moment everything is fine. Happy to (re)test, probably more helpful when the behaviour reoccurs.

Hmm, seems weird.

Would you try editing notes when the issue occurs? Also try changing dates or other values too to see if it sticks.

It happens no matter what information I change:

  • Due date
  • Subject line
  • priority
  • Subtask
  • Notes

It happens almost every time a change is made.

Restarting GoodTask sometimes stops the problem, but not always.

It's about iCloud reminders (I haven't tested it with Exchange tasks yet).

I don't know, whether the changes are correct in the Reminder app.

It is really annoying

Hi @TRq, thanks for the details. I'm not sure if this may help but would you try 'Preferences - Advanced - Hide Completed tasks' and see how it goes? After doing it, run 'Delete local cache files' and restart the app and see how it goes.

Completed Tasks are already hidden.

Or do you mean:
(second to last option).

I do NOT want to delete my completed tasks.

I already deleted the local cash.

Yes, that's what I mean. It doesn't delete completed tasks but only hides them in GoodTask.

For now everything is fine. If it reoccurs, I'll record my screen. The behaviour occured with changing dates as well, if I recall correctly. I will test this too at next opportunity.