GoodTask 4.9 Release Note

#1

Hi everyone. Finally GoodTask 4.9 has come.

On this update, you get much better performance along with new iOS 13 features including multi-window and conversational shortcuts. Check below for details.

  • Lists/Calendars order will not sync with previous versions. Make sure to update all your devices with version 4.9.0 :slight_smile:

Better Stability and Performance

  • This update brings much better stability and overall performance improvements throughout the app

iCloud Sync Settings


Comment : iCloud Sync menu has moved up the ladder and became top settings option. You can choose to use 'Automatic Preferences Sync' like before which does the sync automatically or use manual 'Upload / Download' button to selectively sync at your needs.

  • With all the data under the hood changing, automatic preferences sync has been expanded to 'iCloud sync'. You can choose to automate the process or manually upload and download. Also you can selectively sync lists-related preferences.

  • Lists used inside GoodTask validates connection between Reminders database. If you use different data sources between multiple devices, you should turn off sync for 'Lists'. Also if you have upgraded your database for iOS 13 and macOS Catalina but you're still using previous OS on some devices, turn off sync for 'Lists' on those previous OS using devices to make it work smoothly.

  • Turning off 'Lists' will remove sync for 'Lists', 'List Order', 'Excluded Lists & Calendars' and 'Favorites'.

  • Task properties such as 'Repeat after completion', 'Auto-snooze' and 'Manual Sort' are synced for iCloud lists in part of iCloud sync.

Multi Window Support on iPad

Comment: Yes, it's possible to have 3 GoodTasks on one screen

  • You can open multiple windows of GoodTask at once! :slight_smile:
  • Use Keyboard shortcuts to directly add (CMD-CTRL-N), close (CMD-W) and switch focus (CMD-`) between windows.

Better Shortcuts Support

  • Inside Shortcuts app, you can add GoodTask action of 'Add New Task', 'Complete Task' and 'View List'.
  • You can adjust parameters based on your needs

Other changes

  • Fix for Today Widget : Notes not following display options
  • Reminders Backup feature is removed. If you need to use previous RLB files, get 'Backup Reminders Lists' app in App Store.
  • Priorities shown while sharing lists
    & Other adjustments and bug fixes

.

While you may not notice, there are lots of things going on under the hood. I've made an indicator when the app is communicating with Reminders database. On iOS, it's hidden on top of the tasks next to search icon. You can only see it if you pull the tasks down like below screenshot.

s3

Also the indicator has changed to an icon on macOS version to simply inform rather than give distractions.

You don't need to give those icons attention since it'll just do their job even if you're not in the app but it would be nice to know when you want to know the current status. :slight_smile:

Hope you enjoy the app and get more things done. Now I'll start working on next update with more exciting new features. Thanks! :smile:

.
.
.

app-store app-store-mac

pinned globally #2
#3

Although the app store suggests I have the current version,the about screen days 4.8.5.

Is this correct

Ian

#4

No, it should show 4.9. This is somewhat common issue on Mac App Store.

  • Try re-opening Mac App Store.
  • Check if GoodTask is in Application folder on your Mac.
  • Try restarting the device.
  • Check Purchased screen on Mac App Store (which can be accessed through your name on bottom left)

If all doesn't work, you may need to re-install the app.

#5

I'm talking ios did I miss something.

#6

iOS version should show 4.9 too. Try restarting the device or restart App Store app.

#7

I had to force the update on my Mac too.

#8

For other reasons I deinstalled and reinstalled the app on my iPhone and iPad before the last update. After installing the new update (4.9) the smart lists wasn’t there anymore. Had to create them again. When i did this, there were som weird behaviors, like no list count of tasks (There was neither a zero nor a number to be seen in the list view. Had to restart the app). This never happened before. And now i can see that the Apple Watch app doesn’t work. As soon as i try to click the complication, the screen flickers for a moment but then nothing. Doesn’t open the app.

#9

Since upgrading to 4.9 I no longer see the icon to ‘Open URL’ when I swipe on a task, despite this working before updating. I have removed and reapplied the setting and also restarted the app without success. Other swipe actions are there and work as expected.

Anyone else seeing the same thing?

#10

I also don't see the "open URL" option on swipes.

#11

@dwm, @BoEast, thanks for the feedback. 'Open URL' issue will be fixed on next 4.9.1 update.

@BoEast, do you mean all your lists were reset and went to default? About the watch app, does the app not opening at all? Would you try re-installing and see how it goes?

#12

Hi and thanks for the reply. I don’t know how it is supposed to work but I did delete GT on both iPhone and iPad and I know that I have to install the theme again in this situation. But when i opened the app, only the native reminders lists were there. My smart lists were replaced with the default ones that are there when you install for the first time. All the other settings seemed to be ok though.

I have tried to delete - reinstall the app on the watch, no change. Then i tried to delete - reinstall on my iPhone, and re-start my iPhone and watch. No change. If i try to click right now on my watch, it tries to open the app for a brief second but then I’m back again on my watch face. The same if i try to open the app from the app-list on my watch.

#13

Thanks for detail info.

  • Would you check inside 'Settings - iCloud Sync - Backup' and see if you have previous data there? If you have them, try uploading current settings and restore from previous ones to see if things can be restored.

  • Inside iPhone's watch app, go into 'GoodTask' and try uninstall - install with 'Show App on Apple Watch' switch. On iPhone app, check if you have 'Favorites' set. Open the app on the watch and see if it shows 'No Items' or any changes.

#14
  • i only have backups from today which is after installing 4.9.

  • Already tried this (and did it again now) still the app can't be opened on the watch. And I do have some favorites set.

#15

Would you try below?

  • Uninstall watch app
  • Restart the watch
  • Re-install watch app

Also check default Reminders app to see if it's working properly.

I'm not getting any crash reports yet to figure out in more detail. It may need some time. :sob:

#16

Tried it now. Even did a hard reset on the watch in between. No change.

Reminders app works fine.

#17

I'll check when report comes in. Would you give me what device and watchOS version you're using? Thanks!

#18

Serie 4. Watchos 6.01

1 Like
#19

More weird things are happening. Every time I edit a smart list, there is no list count when I come back to the list view. I have to close and open the app.

#20

Thanks for the report. It’ll be fixed soon. Meanwhile you may edit list on the lists page by swiping. I’m sorry about inconvenience. :sob: