Incorrect work of alert

#1

Greetings!
I started using your application quite recently and I really like it. I switched to it from another ToDo manager. But one problem upsets me and I cannot understand why it appears.
For example, I create a new task with a due date of 9:00 am. An alert is automatically generated for the same time. I also have enabled Auto-Snooze (every 10 minutes 5 times). BUT! Sometimes for some reason, the first alert comes at 9:10, and not at 9:00! This behavior is not found in all alerts and I can't understand why this is happening?

#2

Hi @zzonderr, thanks for using GoodTask. It doesn't seem to be obvious behavior and I haven't seen anything like it yet. Do you see any patterns or any behavior which may have caused it?

Thanks!

#3

Unfortunately, I can’t understand why some reminders have this behavior. This problem occurs rarely. However, I found some details:

  1. If in this task change the due date, it will come again with a delay (in my case delay is 10 minutes). Also, this task has 1 less notice. There should be 1 notification for the task itself and 5 notifications for the Auto-Snooze - total 6. But this task has only 5 notifications. It seems that the notification from the task itself is not displayed, and Auto-Snooze notifications come in full (5 pieces).
  2. After I turned on notifications from the standard iOS Reminder application, the first notification comes in time only from it. GoodTask is silent. After 10 minutes, GoodTask sends its first notification.
  3. Even after the task is marked completed, I remove the mark of completed and set a new due date. The problem with delay of notifications repeats.
#4

Does this occur on one device with all the settings set on the app itself?

Would you give me details of the task if you can replicate it all the time? (like on 3.?)

#5

Yes, it all happens on one device. I use the application on only one device. After installing the application, I set all the settings in it manually.

I just found out that notifications of this task can work normal, but it depends on the due date. What connection is I don’t understand. I set the due date for today at 5:00 pm and the first notification arrived in time. Then at the same moment I changed the due date for today at 5:05 pm and the first notification came at 5:15 pm.

Attached screenshots.

#6

And a task has appeared again that has no first notification (in the screenshots). Why such last modification date is indicated? At specified time I didn’t do anything with this task. I looked through the remaining tasks and they all have the same last modification date. Is this normal?

#7

Hi @zzonderr, normally any actions you make to modify the task will change modification date. If you haven't made any changes, it shouldn't normally change. Do you have any other services that's connected to Reminders database which may be modifying the data?

Also do you have 'Auto-Snooze' turned on as default? Would you try with that turned off?

Thanks!

#8

No, there are no such services.

Yes, Auto-Snooze was on by default (every 10 minutes 5 times). If I turn it off, the first (and single) notification always arrives on time (checked about 10 times). When global Auto-Snooze is enabled (any value), the first notification does not come. This behavior is observed even if Auto-Snooze is disabled in the task itself.

#9

Hmm, it seems like a weird bug. I've checked and tested several times but couldn't find any issues.

v4.7.0 update is rolling out so please update the app when it's available and try if it works well on the version. If it still doesn't work, tell me back. Thanks!

#10

Unfortunately, the update didn’t help. The first notification still doesn’t come. I created a new list in which I created a test task and recorded a video of how notifications come. Maybe this will help. I really like your application, but upset by this bug. The first notification is often very critical.
Video:

#11

Hi @zzonderr, thanks for detail info. I've checked the video and it seems like your 'closing the app' behavior could be causing the issue. When closing the app, you should not swipe up the app on app switcher. This closes the app completely and stops all the actions that should run. Try simply closing the app by leaving it on the app switcher and see how it goes.

Thanks!

#12

I set a new due date, closed the application but didn't close it in the app switcher then blocked the phone. The result is the same. The first notification doesn't come :disappointed:

P.S. Is there any way to pull out the logs of work (if they are)?

#13

Hmm, weird thing. Please try below.

  • Inside GoodTask's settings - General - Notifications, turn it off and turn it back on. Set 'Auto-Snooze' to off and then turn it back on.
  • Try restarting the device once
  • After that, try making a new task with an alert.
#14

All done in steps. Didn't help.

#15

I'd like to check few things.

  • Does it work normally if you don't have 'Auto-Snooze' set?

  • If you make a task with 'Auto-Snooze' default settings off and 'Auto-Snooze' set for that task only, does it work correctly?

  • If you have 'Auto-Snooze' default settings on, does all the tasks with alert not work correctly?

  • If you have 'Auto-Snooze' default settings on and have specific task with auto-snooze turned off, does it's alert work correctly?

Thanks!

#16

Correctly works. If global 'Auto-Snooze' is 'none' and the task individual setting of 'Auto-Snooze' is 'none' too then everything works correctly.

Correctly works. If global 'Auto-Snooze' is 'none' and the task have individual setting for 'Auto-Snooze' then everything works correctly.

Not correctly works. If global 'Auto-Snooze' is on, all new tasks doesn't have first notification.

Not correctly works. No notification at all.

Something is wrong with the default settings 'Auto-Snooze'.

#17

Thanks for detail info. I've looked into this deeply but this is totally unexpected behavior and it's hard to reproduce it on my side at the moment. All I can think of at the moment is re-installing the app and see how it goes.

  1. Delete the app.
  2. Restart the device.
  3. Re-install the app.

Normally notifications related to auto-snooze are made after the main alert so this seems to be something other than normal bug. :disappointed_relieved:

#18

It helped me. In addition, just in case, I used Settings > Advanced:

  • Delete GoodTask Releated Fields
  • Delete All Completed Tasks
  • Delete 'Previously Used' Data
  • And deleted all previously created tasks

Now all notifications come correctly.:partying_face: I will follow their work.
Thank you very much for your help! From me the subscription :wink:
Your app is the best! :+1:

#19

Great to hear that it's working now. :smiley:

I'll keep on making the app better. Hope you enjoy the app and get things done well. Have a wonderful day! :slight_smile:

#20

The problem reappeared :sob:. After reinstalling the application, all tasks were created anew. A couple of tasks worked correctly. Then, for the task with a due date of 18:15, the first notification came at 18:25 ('Auto-Snooze' manual setting is 10 minutes 5 times). Now all created tasks do not have the first notification. What kind of magic :exploding_head:?